aboutsummaryrefslogtreecommitdiff
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorTom Smeding <tom.smeding@gmail.com>2020-09-13 17:58:51 +0200
committerTom Smeding <tom.smeding@gmail.com>2021-01-28 22:20:12 +0100
commit5c7677e5fa134b60c7d4c29d3643125901a31fb8 (patch)
tree42bc74f3d2f257f9c013b986d4b5b421cd0fc361 /rust/Cargo.toml
parent7e169db30f3bc899c8708badf39d8ed268ef1968 (diff)
WIP rust client
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
new file mode 100644
index 0000000..2c95d3c
--- /dev/null
+++ b/rust/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "tomsg-rustclient"
+version = "0.1.0"
+authors = ["Tom Smeding <tom.smeding@gmail.com>"]
+edition = "2018"
+
+[dependencies]
+tomsg-rs = { git = "https://github.com/lieuwex/tomsg-rs" }
+termion = "1.5"
+tokio = { version = "0.2", features = ["rt-threaded"] }
+futures = "0.3"
+once_cell = "1.4"
+unicode-width = "^0.1.8"